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LAST CLASS

Google Dremel is the foundation system 
architecture for many modern OLAP systems.
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ADVENT OF SPARK

High-performance and more expressive 
replacement for Hadoop from Berkeley.
→ Separate compute / storage
→ Support for iterative algorithms that make multiple passes 

on the same data set.

Written in Scala (the hot language in 2010), 
meaning that it ran on the JVM.

Originally only supported a low-level RDD API.

Added DataFrame API for higher-level abstraction.

https://db.cs.cmu.edu/
https://15721.courses.cs.cmu.edu/spring2024
https://en.wikipedia.org/wiki/Pandas_(software)#DataFrames
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SHARK (2013)

Modified version of Facebook's Hive middleware 
that converted SQL into Spark API programs.

Only supported SQL on data files registered in 
Hive's catalog. Spark programs could not execute 
SQL in between API calls.

Shark relied on the Hive query optimizer that was 
designed for running map-reduce jobs on Hadoop.
→ Spark has a more feature-rich native API.
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SHARK: SQL AND RICH ANALYTICS AT SCALE
SIGMOD 2013
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SPARK SQL (2015)

Row-based SQL engine natively inside of the Spark 
runtime with Scala-based query codegen.
→ In-memory columnar representation for intermediate 

results as raw byte buffers.
→ Dictionary encoding, RLE, bitpacking compressions.
→ In-memory shuffle between query stages.

DBMS converts a query's WHERE clause expression 
trees into Scala ASTs. It then compiles these ASTs 
to generate JVM bytecode.
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SPARK SQL: RELATIONAL DATA 
PROCESSING IN SPARK
SIGMOD 2015
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JVM PROBLEMS

Databricks' workloads were becoming CPU bound.
→ Fewer disk stalls because of NVMe SSD caching and 

adaptive shuffling.
→ Better filtering to skip reading data

They found it difficult to optimize their JVM-based 
Spark SQL execution engine further:
→ GC slowdown for heaps larger than 64GB
→ JIT codegen limitations for large methods
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DATABRICKS PHOTON (2022)

Single-threaded C++ execution engine embedded 
into Databricks Runtime (DBR) via JNI.
→ Overrides existing engine when appropriate.
→ Support both Spark's earlier SQL engine and Spark's 

DataFrame API.
→ Seamlessly handle impedance mismatch between row-

oriented DBR and column-oriented Photon.

Accelerate execution of query plans over "raw / 
uncurated" files in a data lake.
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PHOTON: A FAST QUERY ENGINE 
FOR LAKEHOUSE SYSTEMS
SIGMOD 2022

https://db.cs.cmu.edu/
https://15721.courses.cs.cmu.edu/spring2024
https://en.wikipedia.org/wiki/Java_Native_Interface
https://dl.acm.org/doi/10.1145/3514221.3526054
https://dl.acm.org/doi/10.1145/3514221.3526054


15-721 (Spring 2024)

DATABRICKS PHOTON (2022)

Single-threaded C++ execution engine embedded 
into Databricks Runtime (DBR) via JNI.
→ Overrides existing engine when appropriate.
→ Support both Spark's earlier SQL engine and Spark's 

DataFrame API.
→ Seamlessly handle impedance mismatch between row-

oriented DBR and column-oriented Photon.

Accelerate execution of query plans over "raw / 
uncurated" files in a data lake.

7

PHOTON: A FAST QUERY ENGINE 
FOR LAKEHOUSE SYSTEMS
SIGMOD 2022

https://db.cs.cmu.edu/
https://15721.courses.cs.cmu.edu/spring2024
https://en.wikipedia.org/wiki/Java_Native_Interface
https://dl.acm.org/doi/10.1145/3514221.3526054
https://dl.acm.org/doi/10.1145/3514221.3526054
https://twitter.com/andy_pavlo/status/1536843474925981697


15-721 (Spring 2024)

DATABRICKS PHOTON

Shared-Disk / Disaggregated Storage

Pull-based Vectorized Query Processing

Precompiled Primitives + Expression Fusion

Shuffle-based Distributed Query Execution

Sort-Merge + Hash Joins

Unified Query Optimizer + Adaptive Optimizations
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SPARK: QUERY EXECUTION

9
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  FROM wikipedia
 WHERE title LIKE "%Pavlo%"
 GROUP BY 1 ORDER BY 2 DESC
 LIMIT 100
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Stage #1
Partial Group By

SPARK: QUERY EXECUTION
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Stage #1
Partial Group By

Stage #2
Group By, Sort, Limit
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PHOTON: VECTORIZED QUERY PROCESSING

Photon is a pull-based vectorized engine that uses 
precompiled operator kernels (primitives).
→ Converts physical plan into a list of pointers to functions 

that perform low-level operations on column batches.

Databricks: It is easier to build/maintain a 
vectorized engine than a JIT engine.
→ Engineers spend more time creating specialized codepaths 

to get closer to JIT performance.
→ With codegen, engineers write tooling and observability 

hooks instead of writing the engine.
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PHOTON: VECTORIZED QUERY PROCESSING

Each GetNext invocation on a Photon operator 
produces a column batch.
→ One or more column vectors with a position list vector.
→ Each column vector includes a null bitmap.

Databricks: Position list vectors performs better 
than "active row" bitmap despite indirection.
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PHOTON: VECTORIZED QUERY PROCESSING

Photon does not use HyPer-style operator fusion so 
that the DBMS can collect isolated metrics per 
operator to help users understand query behavior.
→ Vertical fusion over multiple operators in a pipeline.

Instead, Photon's engineers fuse expression 
primitives to avoid excessive function calls.
→ Horizontal fusion within a single operator.
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HYPER: OPERATOR FUSION

13

Generated Query PlanSELECT *
  FROM A, C, 
   (SELECT B.id, COUNT(*)
      FROM B
     WHERE B.val = ? + 1
     GROUP BY B.id) AS B
  WHERE A.val = 123 
    AND A.id = C.a_id
    AND B.id = C.b_id

for t in A:
  if t.val == 123:
    Materialize t in HashTable ⨝(A.id=C.a_id)

for t in B:
  if t.val == <param> + 1:
    Aggregate t in HashTable Γ(B.id)

for t in Γ(B.id):
  Materialize t in HashTable ⨝(B.id=C.b_id)
  
for t3 in C:
  for t2 in ⨝(B.id=C.b_id):
    for t1 in ⨝(A.id=C.a_id):
      emit(t1⨝t2⨝t3)

https://db.cs.cmu.edu/
https://15721.courses.cs.cmu.edu/spring2024
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SELECT * FROM foo
 WHERE cdate BETWEEN '2024-01-01' AND '2024-04-01';

PHOTON: EXPRESSION FUSION

14
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SELECT * FROM xxx
 WHERE cdate >= '2024-01-01'
   AND cdate <= '2024-04-01';

PHOTON: EXPRESSION FUSION

14

xxx

cdate >= '2024-01-01'
  AND
cdate <= '2024-04-01'

s

vec<offset> sel_geq_date(vec<date> batch, date val) {
  vec<offset> positions;   
  for (offset i = 0; i < batch.size(); i++)
    if (batch[i] >= val) positions.append(i);
  return (positions);
}

vec<offset> sel_leq_date(vec<date> batch, date val) {
  vec<offset> positions;   
  for (offset i = 0; i < batch.size(); i++)
    if (batch[i] <= val) positions.append(i);
  return (positions);
}

https://db.cs.cmu.edu/
https://15721.courses.cs.cmu.edu/spring2024
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PHOTON: EXPRESSION FUSION

14

xxx

cdate >= '2024-01-01'
  AND
cdate <= '2024-04-01'

s

vec<offset> sel_between_dates(vec<date> batch,
                              date low, date high) {
  vec<offset> positions;   
  for (offset i = 0; i < batch.size(); i++)
    if (batch[i] >= low && batch[i] <= high)
      positions.append(i);
  return (positions);
}
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MEMORY MANAGEMENT

All memory allocations go to memory pool 
managed by the DBR in the JVM.
→ Single source of truth for runtime memory usage.

Because there are no data statistics, the DBMS has 
to be more dynamic in its memory allocations.
→ Instead of operators spilling its own memory to disk when 

it runs out of space, operators request for more memory 
from the manager who then decides what operators to 
release memory.

→ Simple heuristic that releases memory from the operator 
that has the least allocated but enough to satisfy request.
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CATALYST QUERY OPTIMIZER

Cascades-style query optimizer for Spark SQL 
written in Scala that executes transformations in 
pre-defined stages similar to Microsoft SQL Server.

Three type of transformations:
→ Logical→Logical ("Analysis & Optimization Rules")
→ Logical→Physical ("Strategies")
→ Physical→Physical ("Preparation Rules")

16

Source: Cheng Lian

https://db.cs.cmu.edu/
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PHOTON: PHYSICAL PLAN TRANSFORMATION

Traverse the original query plan bottoms-up to 
convert it to a Photon-specific physical plan.
→ New Goal: Limit the number of runtime switches between 

old engine (Java) and new engine (C++).
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RUNTIME ADAPTIVITY

Query-Level Adaptivity (Macro)
→ Leverage statistics collected at the end of each shuffle stage 

to re-evaluate previous query plan decisions 
→ This is provided by DBR wrapper.
→ Similar to the Dremel approach we discussed last class.

Batch-Level Adaptivity (Micro)
→ Specialized code paths inside of an operator to handle the 

contents of a single tuple batch.
→ This is done by Photon during query execution.
→ Similar to Velox optimizations discussed in Lecture #05.

18
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SPARK: ADAPTIVE QUERY OPTIMIZATION

Spark changes the query plan before a stages starts 
based on observations from the preceding stage. 
→ Avoids the problem of optimizer making decisions with 

inaccurate (or non-existing) data statistics.

Optimization Examples:
→ Dynamically switch between shuffle vs. broadcast join.
→ Dynamically coalesce partitions
→ Dynamically optimize skewed joins

19

Source: Maryann Xue

https://db.cs.cmu.edu/
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SPARK: PARTITION COALESCING

Spark (over-)allocates a large number 
of shuffle partitions for each stage.
→ Number needs to be large enough to avoid 

one partitioning from filling up too much.

After the shuffle completes, the 
DBMS then combines underutilized 
using heuristics.

20

Worker

Source: Maryann Xue

Partition #1 Partition #3 Partition #4Partition #2 Partition #5
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PHOTON: BATCH-LEVEL ADAPTIVITY

Custom Primitives for ASCII vs. UTF-8 Data
→ ASCII encoded data is always 1-byte characters, 

whereas UTF-8 data could use 1 to 4-byte characters.

Compact Sparse Vectors
→ Copy tuples to new vectors before probing

hash tables to maximize SIMD utilization.

No NULL Values in a Vector
→ Elide branching to checking null vector

No Inactive Rows in Vector
→ Elide indirect lookups in position lists
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TPC-H COMPARISON
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DATABRICKS TPC-DS (2021)

Databricks announced audited TPC-DS results in 
late 2021.

23
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And only old people care about official TPC results!
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SPARK ACCELERATORS

Since Photon is proprietary, there are other open-
source alternatives to accelerate Spark's runtime.

These systems redirect entire query plans to 
separate runtime engines rather than use Photon's 
fine-grain integration.

Notable Examples:
→ Apache Gluten (Intel)
→ RAPIDS Accelerator for Spark (Nvidia)
→ Blaze (Kuaishou)
→ Datafusion Comet (Apple)

24
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OBSERVATION

The lack of statistics makes query optimization 
harder for queries on data lakes. Adaptivity helps 
for some things, but the DBMS can do a better job if 
it knows something about the data.

What if there was a storage service for data lakes 
that supported incremental changes so that the 
DBMS could compute statistics?

25
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DELTA LAKE (2019)

Transactional CRUD interface for
incremental data ingestion of
structured data on top of object stores.

DBMS appends writes to a JSON-oriented log.

Background worker periodically convert log into 
Parquet files (with computed statistics).

26

DELTA LAKE: HIGH-PERFORMANCE ACID TABLE 
STORAGE OVER CLOUD OBJECT STORES
VLDB 2020
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APACHE KUDU (2015)

Storage engine for low-latency random access on 
structured data files in distributed file system.
→ Updates are written to in-memory B+tree and then 

converted to column store when written to disk.
→ Vectorized execution for analytical queries.

No SQL interface (must use Impala). Only supports 
low-level CRUD operations.
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KUDU: STORAGE FOR FAST 
ANALYTICS ON FAST DATA
WHITE PAPER 2015
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APACHE HUDI (2016)

Transactional (MVCC) system for
incremental data ingestion of structured
data on top of object stores.
→ Keeps track of partitioning, versioning, and schema 

changes. Background compaction.
→ Provides catalog service for runtime lookups and pruning 

of meta-data.
→ Supports both Parquet + ORC file formats.

Supports data ingestion from multiple sources:
→ Examples: Kafka, Spark SQL, Flink SQL

28
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Source: Apache Hudi
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APACHE ICEBERG (2017)

Infrastructure and file format extension
to Parquet for maintaining catalog
about data files in an object store.
→ Keeps track of partitioning, versioning, and schema 

changes.
→ Provides catalog service for runtime lookups and pruning 

of meta-data.

Snowflake added support for ingesting, creating, 
and querying Iceberg files in 2021.

29
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PARTING THOUGHTS

The interesting parts of Photon is in it use of 
precompiled primitives and its integration with an 
existing JVM-based runtime infrastructure.

Andy does not recommend building a Java OLAP 
engine from scratch.

30
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NEXT CLASS

Snowflake

31
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